Telegram Quietly End Supports For Older Android Operating System

After WhatsApp
recently cut it ties with Android 2.1 and 2.2, iOS 6 and Windows Phone 7. It
had previously mentioned this move earlier in the year in a blog post. Telegram
take a turn to announce that its leaving behind users running Android 2.2,
Android 2.3 and 3.0 too. Android 4.0 Ice Cream

Sandwich is the minimum
operating system version required to run Telegram’s latest version.

Although not mentioned by Telegram, their motives for ending
support of such old platforms are to enable the software to get more features
which require a new operating system. If you are a Telegram user still running
the Android older version, you can try out Telegram web from your mobile
browser.
Spread the love

16 thoughts on “Telegram Quietly End Supports For Older Android Operating System

  1. Hello uncle yomi, pls I need your opinion on tracing a scammer, I was scammed $500 from a guy online, have managed to get his name and acct number, pls is there any advance way I can get to trace the guy with his mobile number, I have reported the case to police and there response wasn't too optimistic pls I wud be happy if you reply me ..

  2. Prof, i want to know if you know of anyone within the Ogun-Osun-Oyo-Lagos axis that can 'unlock' UK phone….you can tell me how much it will cost if you have an idea the charge.
    Or Betterstill, is there any 'downloadable' app that can get the job done??
    Earnestly anticipating your reply sire.

Leave a Comment